• 0
GSebas

tutorial
Activar Modo Ingeniero (Engineer Mode) RAZR D1/D3

Puntuar esta pregunta

Pregunta

Nota: esto solo funciona en teléfonos con procesador Mediatek

 

Habrán notado que si se intenta abrir esta aplicación ésta se cierra sin más. Analizando el código smali de esta aplicación me encontré que el programa revisa el valor que tiene la propiedad ro.ril.mp.flg :

...    const-string v6, "ro.ril.mp.flg"    invoke-static {v6}, Landroid/os/SystemProperties;->get(Ljava/lang/String;)Ljava/lang/String;    move-result-object v6    const-string v7, "0"    invoke-virtual {v6, v7}, Ljava/lang/String;->equals(Ljava/lang/Object;)Z...

El valor por defecto de esa propiedad es 1 (getprop ro.ril.mp.flg) y debido a que es una propiedad de solo lectura no es posible cambiarla con el comando setprop, para cambiarlo necesitamos del binario setpropex (Enlace de descarga y Fuente). Una vez descargado hay que copiarlo a /system/xbin y darle permisos de ejecución, ahora, como root, ejecutar lo siguiente:

setpropex ro.ril.mp.flg 0

Para comprobar que ha funcionado ejecutar el comando getprop ro.ril.mp.flg y debería devolver el valor 0.

 

Ahora sí, en el marcador de números telefónicos ingresar la siguiente combinación: *#*#3646633#*#*

Y saldrá el dichoso modo ingeniero:

Screenshot_2013-12-26-02-15-39.png  Screenshot_2013-12-26-02-15-46.png

 

Screenshot_2013-12-26-02-15-50.png  Screenshot_2013-12-26-02-15-55.png

 

 

EDITO: Los cambios se pierden al reiniciar, pero me sirve para controlar los niveles de volumen del móvil, por ejemplo el mínimo que me resulta muy alto cuando quiero escuchar algo de música cuando hay silencio. Total que casi no apago el móvil. También el volumen máximo está puesto en 120, y el menú acepta hasta 160, para quien quiera probar a aumentarle de volumen a su teléfono.

Editado por GSebas
aclarar que solo funciona con Mediatek
A 6 personas les gusta esto

Compartir este post


Enlace al post
Compartir en otros sitios

61 respuestas a esta pregunta

  • 0

GrSirius, Habría que ver que dicen los logs. Activar la depuracion usb y conectar el telefono a la pc, en la pc ejecutar en una ventana de comandos (cmd) el programa adb (adb logcat). El programa adb viene con el sdk de android.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Buenas Gsebas hace unos días empece a ver el tema y empece hacer todos los pasos con ayuda de los comentarios de los otros compañeros, instale la terminal, el archivo setpropex lo copie en la carpeta xbin le di permiso de ejecución, mi teléfono (samsung s5 ) esta rooteado (permiso super usuario). el caso es que en la terminal pongo su  luego setpropex ro.ril.mp.flg y no me devuelve 0. y me dice segmentation fault.

que estaré haciendo mal?

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Yo tengo 2 preguntas, la primera es como hago que el archivo sea compatible para poder moverlo a la carpeta xbin, ya que me tira error que solo acepta "solo lectura", y la otra, es como darle los permisos de los que ustedes hablan, gracias y saludos!.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Franco Cazenave, Con un gestor de archivos (ES File Explorer, X-Plore, Root Explorer, etc).

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

buen dia

 

te agradezco me colabores segui tus pasos, guarde el archivo en system/xbin utilice root explorer, le concedi permisos, y ejecute el comando en la terminal y me arroja esto lo hago en un moto g xt1040 lillopop 5.1

post-736811-0-54103900-1447350918_thumb.

Editado por mor614

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

mor614, El error que te sale es porque el binario setpropex no es compatible con Lollipop y versiones superiores de Android. Aún si funcionara no te serviría pues este método es solo para teléfonos con procesador Mediatek y el tuyo tiene un Qualcomm.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Hola Amigo intento copiar el archivo setpropex y no me deja que puedo hacer..

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

cyberdanzer, Edita el archivo /system/build.prop y añade al fina la linea ro.ril.mp.fl=0 , reinicia y ya podrás abrir la aplicación EngineerMode.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

@GSebas gsebas hice todos los paso en evo2 cm980 no me dio problema alguno pero igual no me entra a modo ingeniero podrias ayudarme porfavor gracias....

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

@theemperor No te puedo ayudar porque esto solo funciona con teléfonos con procesador Mediatek y el tuyo tiene un Qualcomm (según un MSM7627).

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

amigo en el motorola moto g1 como activo el modo ingeniero???

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

@GSebas

buenas noches hermano saludos desde venezuela quisiera saber si este método es compatible con el samsung gt-i9300. hice todo al pie de la letra y me salio todo como lo especificaste pero no logro entrar todavía al modo ingeniero..

mi intención d entrar al modo ingeniero xq mi tlf perdió la señal y el imei correcto, logre de tanto buscar hacer que volviera mi imei correcto con una app de la play store y con el modulo xposed framework android pero no tiene señal móvil y creo q entrando al modo ingeniero lo podria solucionar..

de ante mano gracias si m podrias ayudar.. saludos desd venezuela

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

@johan16 Solo funciona si tu teléfono tiene procesador Mediatek, el tuyo no lo tiene.

@alex.jose.190287 Lo mismo, tu teléfono no tiene procesador Mediatek y este método no te sirve.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

@GSebas ok gracias hermano.. y no tienes otro metodo para este tipo de procesador del GT-I9300.. para poder reparar el imei y el numero de serie..?

 ya he probado muchas cosas, como instalar rom originales. y hasta el Android_Revolution_HD-SGS3_53.0 lo instale que segun averigue podia recuperar la señal con eso.. pero nada aun.. y es de resaltar mano que el movil no se conecta el almacenamiento masivo por lo que todas las rom que he instalado ha sido x medio de una sd card..

yo pienso que con odin y instalando el android completo osea( PDA,PIT.BOOTLOADER,PHONE,CSC) podria volver todo a la normalida..

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

oye bro ya hize todo y cuando escribo el comando me aparece esto setpropex: can´t execute: directory que hago bro?

Compartir este post


Enlace al post
Compartir en otros sitios

Registra una cuenta o conéctate para comentar

Debes ser un miembro de la comunidad para dejar un comentario

Crear una cuenta

Regístrate en nuestra comunidad. ¡Es fácil!


Registrar una cuenta nueva

Iniciar Sesión

¿Ya tienes cuenta? Conéctate aquí.


Iniciar Sesión