• Hola, con los nuevos cambios del sitio he puesto diferentes tipos de publicidad que podrian resultar algo molestas. Sin embargo, luego de registrarte e interactuar un poco con la pagina, van a ser reemplazados por otros mas sutiles y pequeños! * A mi tampoco me gusta la publicidad, pero es una de las piezas para que el sitio esté disponible. Si bloqueas la publicidad, probá desactivarla unos dias.
    Gracias

[TRUCO] Acelerar la fijación de satélites GPS en Android

Estado
Cerrado para nuevas respuestas.
OP
OP
C

Caesarivs

Usuario con historia
#16
la 2.3.6 de personal , talves sera porque tenia ICS y luego regrese a la 2.3.6 o nose que xD entonces por las dudas ,en mi caso seria directamente copiar el gps.conf xD
Ensaya copiando directamente, debe ser que en los firm stock no existe tal archivo... si abres el gpsconfig.xml el contenido es similar al del archivo que creaste?
 

Shiruxs

Usuario con historia
#17
Ensaya copiando directamente, debe ser que en los firm stock no existe tal archivo... si abres el gpsconfig.xml el contenido es similar al del archivo que creaste?
hice exactamente eso y nada que ver tiene unos codigos que parecen chino

esto codigo dice :

<?xml version="1.0" encoding="utf-8"?>

<glgps xmlns="http://www.glpals.com/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="glconfig.xsd" >

<hal

acPortName="/dev/ttyS0"

lBaudRate="115200"

cLogEnabled="false"

acLogDirectory="/data/location/com.broadcom.gps/logs/"

ltoFileName="lto.dat"

acNvStoDir="/data/location/"

acCmdPipeName="/data/location/gpscmd"

bAllowIgnoreOsc="false"

bUseHalLogger="false"

/>

<!-- GPS configuration with standalone 26 MHz TCXO and 1.625 MHZ CNTIN -->

<gll

LogPriMask="LOG_DEBUG"

LogFacMask="LOG_GLLAPI | LOG_NMEA | LOG_RAWDATA | LOG_INTEGR | LOG_USR1"

FrqPlan="FRQ_PLAN_26MHZ_2PPM_1_625MHZ_300PPB"

RfType="GL_RF_BARRACUDA_EXT_LNA"

/>

<!-- Periodic Position Fix using default settings -->

<job id="Periodic">

<task>

<req_pos/>

</task>

</job>

</glgps>
 
OP
OP
C

Caesarivs

Usuario con historia
#18
hice exactamente eso y nada que ver tiene unos codigos que parecen chino

esto codigo dice :

<?xml version="1.0" encoding="utf-8"?>

<glgps xmlns="http://www.glpals.com/" xmlns:xsi="http://www.w3.org/20...chema-instance" xsi:schemaLocation="glconfig.xsd" >

<hal

acPortName="/dev/ttyS0"

lBaudRate="115200"

cLogEnabled="false"

acLogDirectory="/data/location/com.broadcom.gps/logs/"

ltoFileName="lto.dat"

acNvStoDir="/data/location/"

acCmdPipeName="/data/location/gpscmd"

bAllowIgnoreOsc="false"

bUseHalLogger="false"

/>

<!-- GPS configuration with standalone 26 MHz TCXO and 1.625 MHZ CNTIN -->

<gll

LogPriMask="LOG_DEBUG"

LogFacMask="LOG_GLLAPI | LOG_NMEA | LOG_RAWDATA | LOG_INTEGR | LOG_USR1"

FrqPlan="FRQ_PLAN_26MHZ_2PPM_1_625MHZ_300PPB"

RfType="GL_RF_BARRACUDA_EXT_LNA"

/>

<!-- Periodic Position Fix using default settings -->

<job id="Periodic">

<task>

<req_pos/>

</task>

</job>

</glgps>
está muy similar en el mio, osea que no, no interfiere... hace el tuto así, y cuentas como te va
 

Shiruxs

Usuario con historia
#19
está muy similar en el mio, osea que no, no interfiere... hace el tuto así, y cuentas como te va
si me andubo por cierto , cuando activas el gps en el motorola milestone 2 vas a configuracion de ubicacion y seguridad , al tildar "utilizar satelites gps" , esto al tenerlo asi se prende el GPS osea me gasta bateria? o solo empiesa a usar el GPS cuando arrancas una aplicacion que utiliza el gps?
 
OP
OP
C

Caesarivs

Usuario con historia
#20
si me andubo por cierto , cuando activas el gps en el motorola milestone 2 vas a configuracion de ubicacion y seguridad , al tildar "utilizar satelites gps" , esto al tenerlo asi se prende el GPS osea me gasta bateria? o solo empiesa a usar el GPS cuando arrancas una aplicacion que utiliza el gps?
Tengo entendido que normalmente no usa la antena del GPS permanentemente, sólo cuando abres alguna app que requiera señal de GPS, tipo Maps o Waze
 

PolderX

Usuario activo
#22
Ir a Configuración del Sistema -> Servicios de localización Activar "Usar Satélites GPS" y "Integrar navegación de google" Reiniciar el dispositivo
hola te consulto donde esta eso en el CM7? estoy queriendo hacer el tuto en mi milestone 2 pero ahi me quede jeje... espero me des una mano gracias.
 

Shiruxs

Usuario con historia
#24
Hola :D mira yo le puse esto hace varios dias ,mi pregunta es si yo tengo 2.3 y actualizo a 4.0 (cm9 ) tendre que hacer todo esto de nuevo?
 

PolderX

Usuario activo
#26
PolderX, en 23 August 2012 - 01:24, dijo: hola te consulto donde esta eso en el CM7? estoy queriendo hacer el tuto en mi milestone 2 pero ahi me quede jeje... espero me des una mano gracias. En la CM7 debe de decir en Configuración -> Ubicación y Privacidad -> Usar A-GPS y Satélites GPS, o algo similar
ahi pude, pero la verdad no me funcaba nada :S demoraba una banda agarre y baje una aplicación que se llama FIX GPS y ahi al toque agarro :D de todos modos buen aporte
 

PolderX

Usuario activo
#27
hola te pregunto ahi probe de nuevo con el tu metodo (lo de GPS fix tengo que abrirlo cada vez q quiero usar el gps) lo hice tal cual decís vos y si agarro al toque los satelites pero es todo rapido cuando usas una conexión a internet osea cuando tengo el wifi activado anda al toque, realmente asusta la velocidad con la que toma los satelites, pero si solo uso el gps demora una eternidad creo que ni los toma porque me canse de esperar y nada :S alguna solución a eso o es que funciona asi el metodo que pasaste? reitero tengo CM 7 y las opciones q tengo son ajustes->ubicaciones y seguridad->despues ahi aparece utilizar redes inalambricas... y utilizar satelite gps marcos las 2 ahi...
 
OP
OP
C

Caesarivs

Usuario con historia
#28
hola te pregunto ahi probe de nuevo con el tu metodo (lo de GPS fix tengo que abrirlo cada vez q quiero usar el gps) lo hice tal cual decís vos y si agarro al toque los satelites pero es todo rapido cuando usas una conexión a internet osea cuando tengo el wifi activado anda al toque, realmente asusta la velocidad con la que toma los satelites, pero si solo uso el gps demora una eternidad creo que ni los toma porque me canse de esperar y nada :S alguna solución a eso o es que funciona asi el metodo que pasaste? reitero tengo CM 7 y las opciones q tengo son ajustes->ubicaciones y seguridad->despues ahi aparece utilizar redes inalambricas... y utilizar satelite gps marcos las 2 ahi...
Si, funciona así :)
 

cheloz

Developer GA
#29
Hola a todos, alguna sugerencia para ingresar los datos de los satelites en ICS??? en donde está el archivo??? ya q GB es diferente
 
#30
hola, yo tengo el mismo problema, no me aparece ese archivo  "gps.conf"  tengo gb stock retail brazil, lo que intente fue crear una carpeta que diga gps.conf, pero me crea una carpeta no el "script" no se si se entiende, como hago para crear   o  pegar directamente el gps.conf" en la carpeta /etc?
 
Estado
Cerrado para nuevas respuestas.